
NetShow Player
Use NetShow Player to play Active Streaming format (.asf) files and live ASF streams. NetShow 
Player can receive ASF information delivered via unicast or multicast. 

If you click a part of the NetShow Player diagram below, its name and other information appears. 



.Asf files are stored ASF streams. .Asf files can be created by building audio files, images, video files, 
and script commands into a file, or by writing an ASF stream to disk.    .Asf files can be played locally 
or can be streamed from a NetShow or HTTP server over a network. 



An ASF stream is a stream of information traveling over a network. This stream can be an .asf file 
sent from a NetShow Server or HTTP server, or it can be live information that the ASF Real-Time 
Encoder has encoded into ASF. When a Real-Time Encoder encodes live information into an ASF 
stream, the encoder sends the ASF stream it creates to NetShow Server, which then delivers the ASF
stream to all NetShow Players. 



An Active Streaming redirector (.asx) file is a small file that passes information to NetShow Player 
necessary to connect to or receive the ASF information. To use an .asx file, open it with NetShow 
Player, double-click it, or run it from a local directory. 



The File menu provides controls to:

· Browse to and open an .asf or .asx file.
· Enter the path to an .asf file or a live ASF stream so that the player will begin streaming the 

information.
· Open the Properties dialog box. It contains many of the Player’s settings, including how many 

times to play an .asf file, what UDP port to use, and whether to receive multicasting.
· Close the ASF stream or .asf file.
· Exit the application.



Use the Go menu to open your browser and access the newest information on the NetShow Home 
Page. The Go menu also has a NetShow Software Updates option that takes you to the NetShow 
Web page where you can download the latest version of NetShow Player. This menu also includes a 
most recently used (MRU) list of the last five URLs that you attempted to stream.



The View menu enables you to set NetShow Player so that it always stays on top. The View menu 
also contains options to view Statistics of the .asf file or live ASF stream, Play Settings for NetShow 
Player, and Markers if you are watching an .asf file. 



Use the Help menu to open the Troubleshooting Guide, the contents of this Help file, or to find 
NetShow Player version information.



The title bar contains the title or alias of the streaming information that NetShow Player is receiving. 
Titles correspond to .asf files. A stream alias corresponds to live ASF streaming. The title bar makes it
easy to identify streaming information even if NetShow Player is paused, stopped, or at an 
unrecognizable point.



The Current Time/Total Time indicator displays how far along in the .asf file you are and the 
complete playing time for the .asf file. Both of these time indications are measured to the tenth of a 
second. This indicator will also display an error if you typed an incorrect URL address. To see what 
the error is, right-click the Current Time/Total Time indicator area and select Error Details from the 
menu.



The Play/Pause button toggles between Play and Pause. When the .asf file begins rendering, the 
Pause button is active because the .asf file is playing. If you pause or stop the .asf file, the Play 
button becomes active.



Click the Stop button to stop playing an .asf file. When you do, the slider returns to the beginning of 
the .asf file. Stopping the .asf file does not break communication with the server. You can click the 
NetShow Player Play button to begin playing the .asf file again.



Markers are a feature of streaming .asf files. Click the Previous Marker button to go back to the last 
marker in the .asf file. The Previous Marker button is active only if the .asf file contains markers and 
if you have passed a marker.



Multicasting is the way NetShow Server delivers a single ASF stream feed to multiple NetShow 
Players. A network must be multicast-enabled in order for multicasting to work. When NetShow 
Server is multicasting, it sends out a single ASF stream that multiple NetShow Players can receive. All
NetShow Players that are receiving the ASF stream are receiving the same stream, similar to how 
everyone watching the same television channel at the same time sees the same thing. When 
multicasting, NetShow Player does not have a connection to NetShow Server; NetShow Player only 
receives what NetShow Server is delivering. 



Unicasting is a two-way, point-to-point connection between NetShow Server or an HTTP server and 
NetShow Player. When NetShow Server is unicasting, NetShow Player can send information back to 
the server while receiving the ASF information. Unicasting can rapidly use up the available network 
bandwidth because each client connected to the server has a distinct connection. 



Click the Rewind button to move backward through an .asf file. If the Rewind button is not active, you
cannot rewind the .asf file. The rewind functionality for an .asf file is available only if you are streaming
the .asf file from NetShow Server and the .asf file has an index. The index is created by the tool used 
to encode the .asf file.



Click the Fast Forward button to move forward through an .asf file. If the Fast Forward button is not 
active, you cannot fast forward through the .asf file. The fast-forward functionality is available only if 
you are streaming the .asf file from NetShow Server and the .asf file has an index. The index is 
created by the tool used to encode the .asf file. 



Click Next Marker to move to the next marker in the .asf file. Markers are analogous to tracks on a 
compact disc. The Next Marker button is active only if you are streaming an .asf file from NetShow 
Server and the .asf file contains markers. Because markers must be created when the .asf file is built,
not every .asf file will contain markers. There are no markers in a live ASF stream.



The vertical lines under the slider indicate the location of markers. Markers are a feature of 
streaming .asf files from NetShow Server. If you place the mouse pointer on a marker, the name of 
the marker and the time that it marks appears. Markers appear only in .asf files and only if they are 
built into the .asf file. Markers will not appear in an .asf file streamed    via HTTP. Markers cannot be 
part of a live ASF stream.



The Slider points to the current location in the .asf file timeline. If the .asf file has an index, you can 
use the slider to move forward or backward in the .asf file. This is the same as using the Previous 
Marker and Next Marker buttons; that is, you must be streaming the .asf file from NetShow Server in 
order to move forward or backward in the .asf file. 

The slider does not move if you are receiving a live ASF stream.



When playing an .asf file or receiving a live ASF stream, the images or video appear in the NetShow 
Player window (provided that there are visuals in the stream). When the mouse icon is a hand, left-
clicking the window has the same effect as clicking the Play/Pause button. When the mouse icon is a 
hand, right-clicking the window opens the short cut menu.



Opening an .asf File 
NetShow Player has two ways that you can play .asf files. Use Open File to open the .asf file or .asx 
file by browsing servers and directories, or use Open Location to type the direct path to an .asf 
or .asx file. 

If you open an .asf file locally, you will not be streaming the file; you will be playing the file from your 
computer’s cache. If you open an .asx file, NetShow Player will stream the .asf file from a server. If 
you enter the URL to an .asf file, you can stream a file from a NetShow server or    HTTP server.

See Also:

 Browsing to Open an .asf File
 Entering the Path to an .asf File



Browsing to Open an .asf File
Use Open File to find an .asf file when you aren’t sure of the exact path to the file, but you are sure 
that you have access to it.

1 On the File menu, click Open File.
2 In the Open dialog box, browse to the directory that contains the .asf file.
3 To begin playing the .asf file, double-click it.

NetShow Player appears, buffers some of the .asf file, and then begins playing it. Playing an .asf 
file in this manner does not stream the file.

See Also:

 Opening an .asf File
 Entering the Path to an .asf File



Entering the URL for an .asf File
Use Open Location to stream an .asf file from a NetShow or HTTP server. 

1 On the File menu, click Open Location.
2 In the Open Location dialog box, type the path to the .asf file. 

If you want to stream an .asf file from a NetShow server, specify the MMS protocol (for example, 
mms://server/file.asf). If you want to stream an .asf file from an HTTP server, use the HTTP 
protocol (for example, http://server/file.asf).

3 To begin playing the .asf file, click OK.
NetShow Player appears, creates a buffer for the .asf file, and then begins playing it.

See Also:

 Opening an ASF File
 Browsing to Open an ASF File



Microsoft NetShow Player Properties Dialog Box
The Microsoft NetShow Properties dialog box is the main source of information within NetShow 
Player. The Properties dialog box contains six pages of information; seven if the .asf file contains 
markers. Each property page presents specific information about NetShow Player, the .asf file, or the 
live ASF stream. Click the page below to learn more about its properties.

See Also:

 General property page
 Details property page
 Settings property page
 Statistics property page
 Advanced property page
 Channel property page
 Codecs property page
 Markers property page



Viewing General Information
Data contained in the General property page comes from the creator of the .asf file or live ASF 
stream. This information is added during creation and can provide details about the content. Not 
all .asf files or live ASF streams contain general information.

 To view the General property page
· On the File menu, click Properties.

The General property page opens.
See Also:

 General property page



General Information Property Page
The General property page exposes any Title, Author, Copyright, Rating, and/or Description 
information that the author included with the .asf file or live ASF stream. 

See Also:

 Properties dialog box
 Viewing the General property page
 Details property page
 Statistics property page
 Advanced property page
 Codecs property page
 Channel property page
 Settings property page
 Markers property page



Channel Property Page
The Channel property page offers information about the Channel Service that is streaming the live 
ASF stream such as the name, its location, a phone number to call, e-mail address, and description of
the channel. This information is contingent on the system administrator making it available. This panel
will not appear when receiving an .asf file.

See Also:

 General property page
 Details property page
 Advanced property page
 Codecs property page
 Markers property page
 Settings property page
 Statistics property page



Viewing the Codecs Used 
You can view the codecs that were used in the .asf file or live ASF stream with the Codecs property 
page. This page identifies the codecs associated with the various image, audio, and video files and 
whether or not the codec is installed on your computer. Understanding which codecs were used in 
building the .asf file and whether your computer has those codecs installed will help you track 
potential rendering problems.

 To view the Codecs property page
1 On the File menu, click Properties.

The General property page opens.
2 Click the Codecs property page.
See Also:

 Codecs property page



Codecs Property Page
The Codecs property page identifies the codecs used in the .asf file and whether or not those codecs
are installed on your computer. The Codecs property page also provides the URL to the NetShow 
codecs Web page. Please see this URL if you want more information about the codec.

See Also:

 Viewing the Codecs Property page
 Properties dialog box
 General property page
 Settings property page
 Details Property Page
 Statistics property page
 Markers property page
 Channel property page
 Advanced property page



Viewing the Details of the .asf File
Whereas the General property page shows any additional information that may have been added to 
the .asf file or live ASF stream, the Details property page provides specific information about the .asf 
file such as length, date of creation, and so on.

 To view the Details property page
1 On the File menu, click Properties.

The General property page opens.
2 Click the Details property page.

The Details property page opens.
See Also:

 Details page



Details Property Page
The Details property page provides information (in addition to the General property page) that is 
useful for understanding how the .asf file streams across the network. This information is part of 
the .asf file, but is not placed there by the author. NetShow Player picks up this information from 
the .asf file or live ASF stream. The Details property page includes:

· Source Link      Path to the streaming .asf file. This will say Multicast if the stream is being 
multicast.

· Creation Date      Date when the .asf file or live ASF stream was created.
· Duration      Length of the .asf file. This will be blank for a live ASF stream.
· Bandwidth      Bandwidth that the .asf file or live ASF stream was designed for. The content author 

determines the bandwidth during the build process.
· Error Correction      Describes the error correction used (if any).
· Image Width      Width of the NetShow Player screen.
· Image Height      Height of the NetShow Player screen.
See Also:

 Properties dialog box
0 Viewing the General property page
1 General property page
2 Settings property page
3 Statistics property page
4 Advanced property page
5 Codecs property page
6 Channel property page
7 Markers property page



Statistics Property Page
Use the Statistics property page to monitor how well NetShow Player is receiving ASF information. 
The Statistics property page contains a three-color pie chart that interprets the number of packetsof 
ASF data that were received, recovered, and/or lost. There is also a progress bar along the bottom of 
the Statistics property page that displays the reception quality over the last 30 seconds.

See Also:

 Properties dialog box
 General property page
 Settings property page
 Details property page
 Advanced property page
 Codecs property page
 Channel property page
 Markers property page



Settings Property Page
The Settings property page enables you to choose how many times to play an .asf file. You can also 
choose the size of the NetShow Player window and the type of controls available on NetShow Player.

See Also:

 Properties dialog box
0 General property page
1 Details property page
2 Advanced property page
3 Codecs property page
4 Channel property page
5 Markers property page



Markers Property Page
The Markers property page displays the times and a description of all markers in the .asf file. The 
Markers property page appears only if the .asf file contains markers. A live ASF stream will not 
contain markers.

See Also:

 Using Markers
0 Properties dialog box
1 General property page
2 Settings property page
3 Details property page
4 Advanced property page
5 Codecs property page



Advanced Property Page
The Advanced property page enables you to set the buffering and protocols that NetShow Player can
receive.

Buffering
The buffer is the amount of ASF information (measured in seconds) that NetShow Player “saves up” 
ahead of what is playing. NetShow Player uses the information stored in the buffer to fill in gaps in the
ASF stream caused by network traffic.    You can use the default buffer, or if you know that you may 
experience heavy network traffic, you may want to set your own buffer. 

Protocols
The protocol settings are the various ways that NetShow Player can receive ASF information. 
Multicasting, TCP, and HTTPare enabled by default. Select the protocols that you want to enable. 
Select    UDP streaming if you are on a local or high bandwidth network that does not have large 
delays caused by network traffic, otherwise do not select this protocol. 

See Also:

 Properties dialog box
 General property page
 Settings property page
 Details property page
 Channel property page
 Codecs property page
 Markers property page



UDP is a protocol that can be used to deliver ASF information from NetShow Server. UDP provides 
connectionless service for unacknowledged delivery, that is, a server using UDP transmits information
to the client and doesn’t wait to hear if the client received the information. UDP tends to work better 
on intranet or local area networks than it does over the Internet.



TCP is a standard networking protocol that every computer on the Internet supports. TCP is a reliable 
protocol which will ensure that you won’t lose information when watching an .asf file or ASF stream. 
However, the drawback to ensuring reliability is that at times network traffic may force NetShow 
Player to wait for ASF information to be delivered. 



HTTP is the protocol used on the Internet to send Web pages, graphics, and so on. This protocol is 
often used to go through firewalls. When using this protocol, be sure that you select the proxy settings
that NetShow Player will use.



Adjusting the Number of Times an .asf File Plays
You can set NetShow Player to play an .asf file a fixed number of times, or continuously.

 To set the number of times an .asf file plays
1 On the View menu, click Settings.

The Settings property page opens.
2 On the Settings property page, click Play Count and then specify the number of times you want to

play the .asf file.
—Or—

 To play an .asf file continuously
1 On the View menu, click Settings.

The Settings property page opens.
2 On the Settings property page, click Play Forever.
See Also:

 Properties dialog box
 General Information
 Details
 Using Markers
 Statistics



Viewing Statistics of the Streaming .asf File
If the .asf file you are watching seems choppy or the file stops playing while NetShow Player buffers 
ASF data, you can check how much information you are receiving. The Statistics property page 
displays several types of information. 

 To view the Statistics property page
· On the View menu, click Statistics.

The Statistics property page appears.
See Also:

 Statistics Page



Adjusting the Window Size
Unless specified otherwise, the NetShow Player window sizes to the height and width of the .asf file. 
If you want, you can resize the window based on the original size of the .asf file.

 To resize the NetShow Player window
1 On the View menu, click Play Settings.

The Settings property page opens.
2 From the Window Size menu, select a size.

Default Size is the original .asf file size. Half Size is half of the original .asf file size. Double Size 
is two times the original .asf file size.

3 Click Apply and then click OK.
See Also:

 Settings property page



Hiding and Displaying Controls
You can set NetShow Player to three possible control views—No Controls, Simple Controls, or Full 
Controls. No Controls means that none of the Player controls are visible. The Simple Controls option 
displays all controls except the Previous Marker, Next Marker, Fast Forward, and Rewind buttons. Full
Controls displays all Player controls.

 To adjust NetShow Player controls
1 On the View menu, click Play Settings.

The Settings property page opens.
2 On the Controls menu, select a controls view.
3 Click Apply and then click OK.
See Also:

 Settings property page



A marker is a pointer to a specific point in an .asf file. Use markers to jump forward or backward in 
an .asf file. Markers exist in an .asf file only if the author creates them. If an .asf file contains markers,
there will be vertical dashes under the slider. Place the pointer on a dash to see the name and time of
the marker.



Using Markers
You can access markers in an .asf file either by clicking the Previous Marker or Next Marker button, 
or by choosing a marker in the Markers property page. 

 To use the Markers property page
1 On the View menu, click Markers.

The Markers property page opens.
2 In the list of markers, select the marker you want to go to and then click the Go To Marker button.

NetShow Player finds the marker, but the Microsoft NetShow Properties dialog box remains.
3 To return to NetShow Player, click OK.

NetShow Player buffers the .asf information and then plays the .asf file from that marker.
— Or —

 To use the Next Marker or Previous Marker button
· Click Next Marker or Previous Marker to move forward or backward one marker.

The slider moves one marker for each time you click Next Marker or Previous Marker. After the 
slider moves to the marker, NetShow Player buffers the .asf information and then plays the .asf file 
from that marker.

See Also:

 Properties dialog box
 Markers property page



Setting a Proxy Server for HTTP Streaming
NetShow Player automatically understands how to receive ASF information via HTTP streaming by 
checking the proxy settings on your default browser (as long as you’re using a Netscape or Microsoft 
browser). If your browser works fine, but you are having a problem receiving HTTP streaming, adjust 
the proxy server that NetShow Player is using.

 To set a proxy server
1 On the File menu, click Properties.

The General property page appears.
2 Click the Advanced property page.
3 On the Advanced property page, select the Use proxy for HTTP streaming check box.
4 In the Server box, specify the name of an HTTP proxy server.
5 In the Port box, specify the number of the port that the server will use.

Port 80 is the usual port number to specify.
See Also:

 Advanced property page
 General Information



Using a UDP Port to Receive an .asf File
If you require a specific UDP port to receive streaming information through a firewall, you can set the 
port using NetShow Player. 

 To set a UDP port
1 On the File menu, click Properties.

The General property page appears.
2 Click the Advanced property page.
3 On the Advanced property page, select the Use the following UDP port check box.
4 Enter the number of the UDP port.
See Also:

 Advanced property page
 General Information



Adjusting an .asf File’s Buffer Time
You can adjust the amount of information that NetShow Player uses for buffering during playback. By 
minimizing the amount of information that is buffered, you will decrease the time it takes for an .asf file
to start rendering; however, you may experience interruptions or delays, especially when receiving 
streaming information over the Internet. 

By maximizing the buffer information, you will increase the time it takes for an .asf file to start 
rendering, but you will decrease the number of interruptions or delays.

Note    Any changes made in the buffering time will not take effect until the next .asf file is streamed.

 To adjust the buffering time
1 On the File menu, click Properties.

The General property page appears.
2 Click the Advanced property page.
3 On the Advanced property page, adjust the Buffering Time slider.

When you first open the Advanced property page, the slider appears in its default position.
See Also:

 Advanced property page
 General Information



Troubleshooting
Use the following error messages to link to a possible solution or at least help you understand what 
the problem is.

Error Messages
”  The specified stream type is not recognized  .”
“  The network connection failed.  ”  

Symptoms
 Can  ’  t get NetShow Player to work with the 16-bit version of Internet Explorer or Netscape 2.0.  
 Can  ’  t connect to a v.1.0 NetShow Server  
 Can  ’  t connect to a server while using Dial-up Networking   
 All I see is a black screen.
 Screen is frozen and the current time/total time indicator continuously shows   “  Buffering.  ”  
 Audio is distorted and/or video is choppy

Return to overview.



Error Details
There is an error with the address entered in the Open Location box. 

To check what may have occurred 
1 Right-click the NetShow Player window.
2 In the drop-down menu, click Error details. 

The Error Details box appears.
3 The Error Details box lists the errors beginning with the first error found.

Return to Troubleshooting.



Failed Network Connection
One possible reason that you may get this message is that your NetShow Player settings may conflict
with your Internet Explorer setting. This will occur if you adjust the NetShow Player protocol settings in
the Advanced Settings tab and do not restart NetShow Player. Clicking Apply will not cause these 
changes to take effect.

Return to Troubleshooting.



Browser Incompatibility
NetShow Player doesn’t work with the 16-bit version of Internet Explorer or Netscape Navigator 2.0.

Return to Troubleshooting.



Won’t Work with v.1 NetShow Server
NetShow Player’s v.2 default configuration for unicast connections is to establish a TCP connection 
with the server. Previous releases would have tried to use UDP to establish a connection. Because 
NetShow v.1 servers support only UDP connections, the NetShow v.2.0 client will fail to connect to a 
server when using its default protocol settings. To use a v.2 client to access content on a v.1 server, 
go to the NetShow Player File Properties dialog, select the Advanced tab, and in the Protocols 
group, select UDP. Close NetShow Player and then try again to access the v.1 server.

Return to Troubleshooting.



Dial-Up Problems
When using dial-up networking to access a network, you can encounter some problems. These 
problems are usually caused by incorrect settings for the proxy server that a firewall is using. 

Verify that your proxy settings are correct

· On the Advanced tab of the NetShow Player Properties dialog box, for the HTTP protocol, select
No proxy. 

Return to Troubleshooting.



Black Screen
When NetShow Player opens and the opening animation stops, if all you see is a black screen, you 
should check to see if you have the correct codec installed to render the video. 

To check if you have the correct codec installed
1 Click the right mouse button on the player window and select Properties. 
2 In the NetShow Player Properties dialog box, select the Codecs tab. The codecs used to compress

the ASF information are displayed.
3 Verify that the video codec used to compress the ASF information is installed on your computer. If 

the codec is not, contact the person who created the ASF stream for information about how to get 
the proper codec. Most content creators will either use standard NetShow codecs or provide a way 
for you to download the codec before watching the ASF information.

Return to Troubleshooting.



Frozen Screen 
When the current time/total time indicator constantly says, “Buffering,” it means that you are using a 
TCP connection to the server. TCP is a reliable protocol which will ensure that you won’t lose 
information when watching an .asf file or ASF stream. However, the drawback to ensuring reliability is 
that at times network traffic may force NetShow Player to sit and wait for more ASF information to be 
delivered. During this waiting period, NetShow Player will display the message, “Buffering,” because 
it is waiting to receive ASF information to use to build up its buffer and continue rendering the ASF 
stream.

Return to Troubleshooting.



Audio is Distorted and/or Video is Choppy
Distorted audio and video is usually caused by one of two things: large amounts of network traffic, or 
the audio and video were created that way.

To judge if network traffic is the problem
1 Click the right mouse button on the player window and select Statistics. 
2 In the NetShow Player Properties dialog box, see how many (or what percentage) of packets have 

been lost. If you are losing more than 5% of the packets, then network traffic is your problem.
3 If NetShow Player is losing only a few packets, check to see if Buffering appears in the Current 

Time/Total Time indicator. If NetShow Player has to constantly buffer information then that means 
that there is network traffic and NetShow Player must wait to receive ASF information. 

If the you are not losing any packets and there isn’t network traffic then there is a good probability that
the content was created that way. Take into consideration the type of ASF content that you are 
watching. Video requires considerably more network bandwidth than image flipping, and the higher 
the audio quality, the more bandwidth that is required. 

Return to Troubleshooting.



Packets are pieces of ASF information. All NetShow content creation tools create ASF information in 
fixed-size pieces. ASF streams and .asf files are comprised of large numbers of packets. When 
an .asf file or ASF stream is sent across a network, NetShow Server breaks the stream into the 
packets and sends those packets out over the network. NetShow Player receives the stream of 
packets and re-assembles the packets and plays the ASF information.



Using NetShow Player with AOL 3.0
NetShow Player can work in the America Online (AOL) browser, as long as the player is registered. 

To register NetShow Player with AOL 3.0
1 Using a text editor, open the AOL browser Viewers.ini file. 

The file is in the AOL3.0 install directory, which by default is c:\aol\viewers.ini
2 Look for the section [Viewers]. If it does not exist, create the section.
3 In the Viewers section, add the line

video/x-ms-asf=NetShow Active Streaming Format (*.ASX, *.ASF)
4 Add the following section to the Viewers.ini file.

[video/x-ms-asf]
Ext=asf, asx
App=C:\Program Files\Microsoft NetShow\Player\nsplayer.exe





*Insert existing text here and delete this text. Do not remove the following paragraph.




